
Getting Started with CelticPipes

Reading this document will get you up to speed quickly and give you a good idea of how 
CelticPipes works.

The document is divided into three sections:

1. Accessing and Loading Tunes

This covers opening, importing, downloading from the tune library and where to save 
edited tunes.

2. Sound

This briefly describes playing a tune, cueing playback and tuning an instrument.

3. Creating a Tune from Scratch

This will take you through writing a complete tune for the Highland Bagpipe. The tune 
contains repeats and first and second timing lines.

Throughout this document, we will use both European and North American terminology 
interchangeably (e.g. measure/bar, quarter note/crotchet etc.)

We will also show screenshots of CelticPipes components running on both the Windows 
and Mac platforms. So, don't be confused if the frame parts of any screen look 
unfamiliar as even on Windows, an XP popup window may have a different border, and 
colour scheme than one on Windows 7.

We recommend that you read (and work along with) as much of the text as possible, Any 
parts which provide additional information will be shown in a separate box like this:
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Note

Text enclosed in a box like this, provides extra information.

It could be skipped, but if you do, it is worth going back over the 
document later to read it as it will give you a better working 
knowledge of CelticPipes.



ACCESSING AND LOADING TUNES

This section presents the following topics:

• Opening CelticPipes files
• Opening other types of file (Importing)
• Saving files

Opening CelticPipe files

CelticPipes file names always end with the .cep extension (this may be hidden on some 
file systems depending on how you have set up your operating system).

They are treated like any other type of file in both Windows and on Mac OS X. You can 
browse for them with Windows Explorer or with Mac Finder and you can copy them, 
move them, delete them or back them up etc. like any other file. You can also attach 
them to emails and send them to someone else who can open them if they have 
CelticPipes.

There are some sample files in the 'Scores' folder under CelticPipes. To open them, go to 
the CelticPipes main menu and choose File->Open. A standard File browser window will 
appear. Navigate to the following location:

    On Mac: /Applications/CelticPipes2/Scores

    On Windows: C:\Program Files\CelticPipes\Scores     [this is the default location]

You should see a list of CelticPipes files. Select the file that starts with 'Hbagpipe1' and 
press Open. The tune will be loaded and its name will appear on the tab at the top of 
the tune.

If you repeat this process for another file at the same location, you will see two tunes 
loaded, in separate tabs. You can switch between each tune by clicking on it's name 
above to switch tabs. You can close the currently selected tab using File->Close. Do the 
same with the other one and you will be left with a blank screen with no tunes loaded.

You can load either of the tunes you loaded using File->Recent Files. This displays a list 
of the last 4 files you have loaded. The number refers to the order in which the files 
were last read; 1 is the most recent. If you select a filename from the list it will be 
loaded. This is a quick way of loading a file if you are working on it a lot. Note: it will 
drop from the list though if you open more than 5 files, but you can easily browse for it 
again.
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The most recent file will be presented on the Welcome screen for easy loading when the 
application restarts.

Exploring for a File

Another way to Open a file is using Mac Finder or Windows Explorer.

To use this, browse to the file (with Finder/Explorer) and double-click on it (or single 
click if you have set your Operating system to activate files using single-click). 

If your application is installed correctly, CelticPipes will run (if not already running) and 
it will display the file automatically, making it the current score.

Tune Library

A number of traditional CelticPipes tunes are available from our online Tune Library. Our 
tune library is currently under Tunes on the top navigation menu bar on our web site.

You can open a file from the collection in one of three ways i.e.:

• Use your browser to find the file you want to open. Right-click on the file and 
select Save Target As. Then save it to a location on your computer that is easy to 
find later. You can then open it using File->Open as described above.
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• Use your browser to find the file you want to open and click on the file. If you are 
using Windows, the file should open automatically in CelticPipes. If you are using 
a Mac, clicking on it will be downloaded to your download folder (under your user 
folder). If you browse to this location in Finder, you will see the file. Double-click 
on it to open it in CelticPipes.

If you like the score you have downloaded, you may want to save it somewhere where 
you can access it later.

• Use the Tunes link on the Help menu (Help->Tunes). This opens up a small browser 
window inside CelticPipes and allows you to browse for the tune. In Windows, if 
you click on the tune inside the browser, it should automatically load in 
CelticPipes. On the Mac, you will again have to go to the download page to find it 
after clicking on in the browser.

Importing

CelticPipes only opens native .cep files. When you want to open a file that has a 
different format, you need to import it. This converts it to a format suitable for 
CelticPipes to read.

The following files can currently be imported into CelticPipes:

• BWW/BMW (Bagpipe Music Writer)

• ABC v1.6 (correctly  formatted!)

• PIO (PiobMaster v1.0 to v2.3) on Windows only (as it is a windows format binary 
file)

• DST (DrumScriobh v1.0 to v2.0) on Windows only, for the same reason.

To import one of these files, choose File->Import from the CelticPipe menu. When the 
file browser appears, locate the file you want to import as if you were browsing for any 
other file and then press the Open button. If the file is a good one, it will import and the 
music should be seen. There may be some errors in the score, so check it for validity. 
You can now save this file anywhere you choose and it will be saved as a .cep file (see 
next).

Saving Files

Any score that is visible in CelticPipes, regardless of how it got there (created manually, 
imported or opened) may be saved to a file with the CelticPipes (.cep) format. You can 
only save to files that have this format. To save to another format, you will need to 
export (see later).

The location you choose to save your files is up to you but certain operating systems 
restrict where you may save them e.g. Windows Vista will often fail silently - which 
makes you think the file is saved, but it is not! Just to be safe, save your files in a 
conveniently named folder under your own User folder. Create one called Scores 
perhaps.
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Exporting Files

With CelticPipes, you can export your scores to BWW, ABC, Image files. Some formats 
(e.g. ABC) will not retain all of the information that may be on the screen. Some things, 
such as colours, fonts, first timing start notes etc. may be lost when exported! An image 
file should look the same though.

It is also possible to export the playback information to a Wave or Midi file. 

To Export a CelticPipes score to one of these formats, choose File->Export and select the 
format you require from the list. Then browse to the location you wish to save the file 
and click the Save button. Now check the file has been saved as expected.

If you have selected to export to an Image file, you will be asked for the required 
quality first.
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A Note about MIDI

A Midi file only contains information about when notes play and what 
instruments are used to play them. They contain NO audio waveform 
information at all – that's why they are so small. Their playback quality depends 
almost entirely on what software they are played back on. Don't be surprised if 
they do not sound realistic. They can be made to sound more realistic using a 
'soundfont' or a good quality VST plugin, on certain playback software.



SOUND

All of the sound functions are accessible from the Sound Toolbar above the score.

If this isn't visible, go to View->Toolbars and on the list that appears, make sure that 
Sound has a tick beside it. This will make the Sound toolbar appear.

Simple playback is achieved by pressing the play button        on this toolbar and waiting 
until the sound has finished. If you want to pause playback at any time, press the Pause 
button         (or press the space bar on the keyboard). To resume, press the Play button 
again (or press your keyboard space bar again). To Stop playing, press the Stop button 
or press Esc on the keyboard. 

Chanter Sound

To play a Great Highland Bagpipe instrument with a practice chanter voice, you can 
temporarily press the chanter button         on the toolbar. It will latch in to indicate that 
it is in operation. Pressing it again will revert to the Highland Bagpipe sound. This option 
will only be enabled if all instruments on the active score are Great Highland Bagpipe.

Sound Options

Sound options can be changed in the Sound section of the Options screen on Windows 
(Tools->Options) or the Preferences screen on Mac (CelticPipes->Preferences). You can 
set a starting E note for bagpipe, extend the last note, enable/disable note indication 
on playback etc.

These settings will be remembered each time the program is restarted.

Written by R. Macleod.                                                                  6                                 © ChorusLogic Ltd., 14rd March 2012

Further Reading

The Help Topics (from Help->Topics) describe more advanced Sound options in 
greater detail in the section entitled Playing a score. It covers topics such as 
cueing from a note, looping a section or setting the pan level of different 
instruments before mixing and saving to wave file.

Keyboard shortcuts are also described in the Help Topics file. They are in the 
section Creating a Score->Keyboard Shortcuts.



CREATING A TUNE FROM SCRATCH

This document will take you through the steps involved in creating a simple bagpipe 
score. If you follow the steps with this document open, you will end up with the 
following tune:

We will refer to this page regularly as we try to build it up from nothing.

The basic steps involved in creating any other score e.g. for drumming, smallpipes or 
whistle are exactly the same, only the instrument and range of notes will be different. 

A basic understanding of music theory is assumed.
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Creating a New Score

This can be done in one of two ways:

1. Start the program and select Create a new File from the Welcome window or,

2. With the program open, select New... from the File menu on the CelticPipes 
menu.
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Whatever method is chosen, the first screen presented is the Titles and Titles & Layout 
page. This is the first of 3 pages of the New Score 'Wizard'.

(The Wizard is designed to guide you through the process of creating a score. It is easiest to fill in as 
much information as you can using this Wizard, but don't worry if you have forgotten anything as 
everything can be added or modified in another way later).

Start by entering the text : 'Mairi's Wedding' in the Main Title textbox.

Continue entering text in the fields as shown in the picture above.

As you can see from the completed score on page 7, we require 5 lines of music and 
each line has 4 bars or measures. The total number of bars or measures in the score is 
therefore 20. So enter 4 for Measures per line and 20 in the Initial no. of measures 
field.

(Terminology: The word 'initial' is used here because new measures may be dropped on to the score at 
any place later, if required, via the Structure toolbar).
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Choose the Paper size you need. This is normally A4 in Europe and Letter in North 
America. It can be changed later using File->Page Properties.

Leave the Advanced settings as they are as the default settings are fine for this small 
tune. We could change them later if we wanted using Tools->Staff Spacing.

Now press Next at the bottom of the screen.

This is where you select the instrument you want to use.
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Advanced
If you know the exact number of bars in your score at the outset, you can use a 
pattern e.g. 5454. This means 5 in the first line, 4 in the second line, 5 in the third 
line and 4 in the fourth line. When this is entered into the Measures per line field 
the Initial no. of measures field will update automatically. 

(For our Mairi's Wedding score, we could have entered 4444 but as every line has 4 
measures we only need to enter 4).



This is a tune for the Great Highland Bagpipe, so we select 'Highland Bagpipe' in the box 
on the left. The Add button becomes enabled. Press Add and Highland Bagpipe appears 
in the box on the right. This is all we need to do.

If you make a mistake, select the instrument in the right box and press Remove. Only 
instruments in the Right box will be used.

Make sure we just have Highland Bagpipe in the right box. Now press Next.
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Exercise
Try adding Side drum or some other instruments to see what else can be done. 
To remove an instrument from the right, select it and press the Remove 
button. If you have Multiple instruments in the right box, you can re-order 
them by selecting on instrument at a time the up or down arrow as many 
times as required.



The Time & Key Signatures window appears:

We want to create a tune that has a Time Signature of 2/4 so click on the right of the 
top listbox (beats in the bar) that currently displays a 4. It will open showing the 
available numbers. Select 2 and it should close and show 2.

Note: The Key signature cannot be changed for Highland Bagpipe. If you had chosen Smallpipes, for 
example, you would have been given the choice of A, D or HP.

The abbreviation checkbox is greyed out as is not relevant for a time signature of 2/4. In CelticPipes, 
the possible abbreviations are C (common) for 4/4 and     (split common) for 2/2. If either of these time 
signatures is selected, the abbreviation checkbox will be enabled for use.

As we are done, press Finish at the bottom of the screen to dismiss the Wizard.
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The score now looks like this:

Note: The BPM indicator may or may not be shown on the score, depending on what is selected in the 
Display section on the Options screen. This can be invoked from Tools->Options on Windows or from 
CelticPipes->Preferences on Mac.

Your basic score is ready now for moulding into the final format by adding repeats, 
voltas (timings) if these are required. In this example, we will add both.

First, let's make the titles and footers a little more attractive.

[It is a good idea to save your score again now].
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Adding a Main Subtitle

Go to the CelticPipes menu at the top of the screen and choose Tools->Titles and 
Footer...

At the end of the text 'Mairi's Wedding', press the Return key to move on to the next 
line. On this line, type '(Mhairi Bhan)'. This is the sub-title in Gaidhlig. In the box 
labelled Second line font size list, select '4 pts smaller'. (Note: Some types of font center like 
this better than others)!

In the Right Footer field, I have entered “Written with CelticPipes” but enter whatever 
you like here.
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If we do nothing else, the titles will be displayed in black in the default font. To change 
the font and colour of the text in these fields, press the Font button to the right of each 
field (apart from blank fields). So, press the Font button in the Main Title section and 
select a font called “Verdana” and give it a point size of 16. Choose a navy blue colour 
for the text. So the same for the Subtitles but make them smaller, say 11. The footer, 
we'll make 8 pts  and a pale 'silver' / light grey.

Scaling is not really relevant for this score - it allows the header to scale with stave 
height. (If you need to make a lot of space on the page by squashing the staves, the  
title can be told to squash up to). You can leave it at None or Auto.

When done, press OK. Now Save your Score by selecting File->Save or File->Save As from 
the CelticPipes menu. You will be asked to give it a file name and for a location to save 
it in. Enter “MairisWedding.cep” and save it somewhere you will remember! Don't rely 
on the Recent File List. Try and keep all your files somewhere under your own User  
folder.

Your titles will now look like this:
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Adding Structure

The next thing we need to do is to create the bar structure of the tune.

We need to define how this tune flows when played. Both the first and second parts of 
this tune are repeated so we need to add repeat barlines.

So, with the score still open, press the 'Show Structure Toolbar' button on the main 
toolbar. (Note: if you hover the mouse cursor over any button on the toolbar, you  
should see a 'tooltip' popup that will describe the button. This is the same on any  
toolbar).

The button looks like this: 

 Press it to show the structure toolbar:

As you can see, some of the buttons on the toolbar are not enabled. These are the ones 
that require an object (usually a note or group of notes) to be selected before we can 
modify it e.g. beam, tie etc. 

As we have nothing selected, we only have access to items that we can apply to our 
empty score. In this case we want to add a repeat barline to the very beginning of our 
score, so click on the Forward Repeat barline button with the mouse         
and let go of the mouse button. The toolbar button will 'latch' in to 
indicate that it is selected. 

With the Forward Repeat button still selected, move the mouse to the beginning of the 
first measure in the score and click on it (click and let go of the mouse button). The 
start barline should change to the required forward repeat barline.

NB: If you make a mistake, at any stage during editing, you can undo in one of several 
ways: 

 Edit->Undo from the CelticPipes main menu or,
 Press the Undo button on the main toolbar          or,
 Ctrl-Z on Windows or Command-Z on Mac.

(There are up to 10 levels of undo in CelticPipes).
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Information
This is how all of these types of button work i.e. ones that don't need a 
selection to become available. They latch and unlatch, indicating that they 
are either off or on. To 'unlatch' you can press another button, press the 
Escape key on your keyboard, or press the arrow button on the main toolbar. 
Some buttons do require a selection to enable. They perform an action on 
something selected. They don't latch.



We need another forward repeat at the start of the third line. As the forward repeat 
button is still 'latched' in, you can simply click on or near the barline you want to change 
at the start of the third line to change it to a forward repeat barline.

We now need to add the backward repeat barlines. To do this, click on the backward 
repeat barline button on the Structure toolbar to latch it in. 

Now, click on the end of lines 2 and 4 to change their barlines into backward repeat 
ones. Now deselect the current toolbar button using one of the three methods listed 
above.

The tune structure is almost correct now. All we have to do is to add the First and 
Second Timing lines or Voltas to the score.

First though, SAVE YOUR SCORE.
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Advanced

If you drop the same style barline that already exists to the first stave line of any 
score, the barline will disappear. You can try this by dropping on a Forward 
Repeat barline on to the one we have just added, just to see what happens. Put 
it back when done.

This gives extra formatting options as some scores have lines that do not start 
with a barline.



Adding Timing Lines and Markers (Voltas)

In this case it is pretty easy as each timing covers a complete line. It gets a bit more 
complicated when you want to cover a small number of bars inside a line. In almost all 
cases though, it is easier to add these timings when the repeat barlines have been put in 
place first, as we have done here.

The fourth line needs a first timing, so press on 
the First Timing button on the Structure toolbar 
to latch it in. 

Now, click inside the first measure on line four 
and you will see a small Properties window 
appear (as shown opposite). The length of the 
marker in terms of bars/measures is calculated 
from the click position to the repeat barline. In 
this case it is calculated correctly (as 4) and no 
manual change is needed, so press OK. The First 
Timing marker should appear in the correct 
place.

If you make a mistake, either select Undo, or drop a marker onto exactly the same place 
and then press the Remove button on the popup window. 

Now press the Second Timing marker button on the Structure toolbar. It should 'latch' in. 
Now click inside the first measure on the last line. Again, the length of the timing 
marker is calculated correctly (4), so just press OK and the marker should appear.

You have now finished adding the Timing markers, so 'unlatch' the button using one of 
the methods explained earlier. Then Save your score.

In the next section, we'll add the notes.
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Advanced
If your score contains notes and you click on to a note head during this procedure, 
rather than on empty space, the Properties popup window will appear with an extra 
option: a 'From note' checkbox will appear on it. If you press OK with this checked, the 
timing marker will begin exactly at the note you clicked. This is a useful thing to know 
for future scores. For now though, we simply need the marker to start at the beginning 
of the line.



Adding Notes

The first thing to do is to drop all of the Root notes into the score. We completely ignore 
any grace notes or embellishments here. (Note: If you try to add grace notes & embellishments 
first, they will all combine! This is a feature of CelticPipes which gives you the ability of adding simple 
embellishments and grace note groupings on the fly).

It helps if you can add the exact note value that you want directly from the toolbar. You 
can add the wrong value and modify it later, but it is more work that way.

The key is that if a note has 1 tail, add a quaver (eighth note). If it has 2 tails, add a 
semiquaver (sixteenth note) etc. That way when you beam, it will look correct, You can't 
beam anything larger than a quaver (eighth note) as it has no tails. (Note: Some 
programs allow this, but they automatically change the note value – we don't do this as  
it can be confusing. What you see is what you get with CelticPipes).

So, let's start putting the notes in the first measure...

Close the Structure toolbar, if it is open, and open the Basic Toolbar by pressing on its 
button (note icon) on the main toolbar. The Basic Toolbar should open.

Click on the quaver (eight note) button and let go of the mouse button. The toolbar 
button will latch in to show it is still selected. The cursor will change to a cross, showing 
that you are about to position something on the score. Now move the cursor to the low A 
position on the stave and click the left mouse button, then let it go. A new note should 
appear in the correct position.
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Exercise
Now we have our first note on the score, it may be helpful to do some things with it.
we can move it up and down in pitch by making sure the note is highlighted and then hold 
the SHIFT key down on your keyboard, keep it pressed and then use the up or down arrow 
key to change its pitch. You can move it further by repeating the process.

 we can move it to the right or left with the same method – SHIFT and Right/Left 
arrow keys.

 The value of a note may be changed either by pressing the /2 or x2 buttons on 
the Basic Toolbar to halve or double the note value (respectively). Or, more 
easily, use the keyboard shortcuts / or * to achieve the same result.

 The note may be deleted if we press the delete button on the main toolbar, or 
press the Delete or Backspace key on the keyboard. (You can try this now and 
then use Undo to get the note back).

Make sure you put the note back to an eighth note on the Low A position.



Our first note should be dotted, so now select it and either press the Dot button on the 
Basic Toolbar (or use the keyboard shortcut which is unsurprisingly a full stop key '.' ). 
The note should become dotted.

For our next note, select a semiquaver (sixteenth note) from the Basic Toolbar and place 
it to the right of the first note, again in the low A position. 

Repeat this procedure dropping the next two quavers (eight notes) on to low A and B as 
shown in the tune on page 1. That is all the notes we require in the first measure.

Now deselect the toolbar button again as before (otherwise we will get in a mess during  
the next bit as extra notes will get placed into the first bar by mistake!).

Save the score again.

Beaming

As the first two notes are already the correct value, they just need to be beamed 
together to connect their common tails (only one common in this case). To beam the 
first two notes, select them both. Their heads should both become blue, indicating that 
they are both selected. With them both selected, press the Beam button on the Basic 
toolbar. The two notes should beam together.

Repeat the beaming process for the next two notes.

Note: use the same procedure if you want to tie notes together, except, use the Tie  
button instead of Beam. For Slurs (which join notes of a different pitch or drum strikes 
with a different hand), you have to use the Slur button which is on the Dynamics and 
Articulations Toolbar       .
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About selecting notes

One note may be selected, either by:
 clicking on its head. Do NOT double-click. Double-clicking is not supported in CelticPipes. 

Or,
 boxing/rubberbanding the note head. This is a procedure where you click on a point above 

or below the note head, keep the left mouse button depressed and drag a box over the 
note head, before letting it go.

More than one note may be selected either by:
 boxing/rubberbanding the note head (see above). This is only useful if the notes are 

adjacent (which is perfect for beaming, tie-ing etc.) or,
 Using Shift-click on the note heads i.e. Press the keyboard Shift key and with the Shift key 

still depressed, click on a note head. Keep the Shift key depressed and then click on 
another note head etc. All the notes you click on will turn blue.

To deselect a note or group of notes, click on anywhere that is not a note. If necessary, use View-
>Refresh (F5) to update the screen.



Carry on adding notes in this way and beaming them until the first line is complete. Use 
the tune on page one as a guide. Don't go any further than the first line as we'll use the 
regularity of traditional music to our  advantage, to help us build up our score more 
easily later on.

Now save the file. 

Adding Grace Notes & Embellishments

To add our first grace note, click on the grace note button on the Basic Toolbar [image: 
grace note button on basic toolbar]. It will latch in. Now click on a space just before the 
first note at a high G pitch. Drop another one on before the second note at a D pitch. 
There are two other grace notes on this line (one in the third and one in the fourth 
measure), so as the button is still pressed in, 'drop' them on. De-activate the button.

That's all the grace notes – now for the embellishments.

The embellishments are found on a different toolbar so, open the Embellishment toolbar 
by pressing the “Show Embellishment Toolbar” button

The Embellishments Toolbar will appear:

This toolbar is divided into a number of 'pages' – each page being accessible from the 
Type list. The default page is Doublings. To see the others, click on the small arrows to 
the right of the Type list, to reveal the list of available embellishment categories 
(pages).

When this list appears, select Bagpipe Movements.
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The first embellishment we want is a Birl. We have a Birl on the top line of the Bagpipe 
Movements page, so on the Bagpipe Movements page, click on the fourth button from 
the left on the top row to select a Birl. (Note: If you hover the cursor over any button,  
you will see the name of the embellishment it represents).

With the Birl button pressed, move the cursor to a position between the second and 
third root notes in the first measure, preferably a bit closer to the third note. Now click 
anywhere in that region. It doesn't matter what stave line or space you click on, the 
embellishment can only click to a specific pitch. The note will appear in position.

If the notes look well spaced in the barlines, that's fine. If they are not, deselect the 
current embellishment button, then click inside the measure you want to space better. 
Now click on the 'Space evenly' button         on the main toolbar. The notes should space 
themselves out better. 

Note: If you try moving a beamed group of notes, the whole group moves. To move an individual note in a 
group, select it only using either SHIFT-click on the note head to select just the note, or 'box' the note 
head of the note you want to select. Then you can move it with SHIFT-<arrow key>.

The next embellishment (in the next measure) is a Throw on D. This is the first button 
on the same line on the Embellishments Toolbar, so click on it. Now click just before the 
first root note in the second measure and the Throw on D will again 'snap' into position.

Continue adding embellishments this way until the first line is complete. Then save your 
score.
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Bar Copy & Bar Paste

If you take a good look at our target score on the first page, we can see that there is a 
lot of repetition, in common with most traditional music tunes. Bars one and two on line 
one are exactly the same as bars one and two on line two. This is also true for lines 
three and four. The last line contains exactly the same notes as line two! This repetition 
makes it a lot quicker to complete our score than painstakingly dropping notes on one at 
a time.

To copy a whole bar, click somewhere inside the bar and right-click (press the right 
mouse button) to display the context menu. 

On this menu, select 'Bar Copy'. Now click inside the 
destination bar, right-click again and select 'Bar Paste' from 
the popup menu. All of the notes should be copied to the 
destination bar. If the notes look squashed up, or not 
aligned well, use the 'Space Evenly' button again as 
described before.

Continue doing this until all of the 'duplicate' bars are 
copied to the correct places. (Note: Be careful about using 
this for notes that have ties spanning bars. It is safest to remove the ties first by  
selecting the notes at the end of the ties and pressing the tie button on the Basic  
Toolbar to remove the ties, before copying). 

Some measures are not exactly the same as other ones further up. In this case, you can 
either use Bar Copy & Bar Paste and then modify the notes, one at a time or you can use 
Copy & Paste.

To Copy & Paste (as opposed to Bar Copy & Bar Paste), you click on a note, or group of 
notes (or box a whole group including embellishments) and then right-click and select 
'Copy' from the popup menu. Then click at the exact location you want to paste the 
note(s), right-click and select 'Paste' from the menu to drop them in. If they go to the 
wrong place, use undo and try again. You can use the standard copy & paste keyboard 
shortcuts (Ctrl-C/Ctrl-V on Windows and COMMAND-C / COMMAND-V on Mac).

Fill in the remaining ones one note at a time as described earlier to complete the tune.

Now Save your score.

If you have got this far, Congratulations! You have just completed your first CelticPipes  
score.
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